Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 30, 2025 - 17:00 CDT
Scheduled
Outage Period: • FSPRD Access: Monday, June 30th, 5:00 pm - Wednesday, July 2 , 7:00 am • Batch Processing (Daily Processing and MUHC Batch Processing): Tuesday, July 1, ~1:00am - Wednesday, July 2nd, 12:01 am • Nightly Batch Processing will be unaffected
The Financials Production Instance (FSPRD) will be unavailable while Fiscal Year-End activities are performed. Batch processing will run to completion on Monday evening and then MUHC and Daytime Batch Processing will be canceled until 12:01 am Wednesday July 2nd.
Please note that during this outage FSRPT and UM Web applications will be available: • The Financials Reporting instance (FSRPT) will still be available. • UM Web Applications will still be available.
What's Affected: Access to the Financials Production (FSPRD) applications (6/30/25 5:00 PM - 7/2/25 7:00 AM) and batch processing (Daily Processes/MUHC processing canceled Tuesday 7/1/25 12:01 AM until Wednesday 7/2/25 at 12:01 AM).
Posted Jun 26, 2025 - 09:15 CDT
This scheduled maintenance affected: Other MU IT Services, Other UM IT Services, and PeopleSoft Finance.