Cable TV outage

Incident Report for UM IT Systems

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 06:16 CDT

Update

Spectrum is continuing to work on the cable TV problem. No estimate on when it will be fixed.
Posted Apr 26, 2026 - 12:57 CDT

Identified

This is a problem that is covering all of Missouri and Illinois.
Posted Apr 26, 2026 - 07:27 CDT

Investigating

We are currently investigating this issue.
Posted Apr 26, 2026 - 07:16 CDT
This incident affected: Other MU IT Services.