VPN issue. Technicians are investigating...
Incident Report for UM IT Systems
Monitoring
System restored and monitoring.
Posted Nov 05, 2024 - 09:48 CST
Investigating
We are currently investigating this issue.
Posted Nov 05, 2024 - 09:42 CST
This incident affects: TigerWiFi, Wired Network, Other MU IT Services, and Other UM IT Services.