US Cellular implemented a change earlier this week to resolve the issues related to call trees and contact center interactions from their users. This change did not resolve the issue and they are continuing to get reports of user problems. They are continuing to work on a permanent resolution.
Posted Mar 11, 2026 - 08:45 CDT
Update
US Cellular continues to work on this issue. New call examples have been submitted for their investigation.
Posted Mar 09, 2026 - 09:07 CDT
Update
US Cellular completed maintenance on their facilities Thursday evening but we are still receiving reports of users unable to to make selections with auto-attendants and call centers. DoIT has been forwarding caller information to US Cellular as reports are received. Users can also contact US Cellular customer service directly to report calling issues.
Posted Mar 06, 2026 - 13:55 CST
Update
US Cellular callers to campus and hospital call centers are currently unable to make keypad selections from their phones. Tthis is an issue with other businesses as well and US Cellular is aware of the issue and working on a resolution at this time. US Cellular has provided no ETA as to when the problem will be resolved but are actively working on the problem.
Posted Mar 05, 2026 - 09:24 CST
Update
US Cellular has been contacted and their engineering team is working on a solution.
Posted Feb 26, 2026 - 08:53 CST
Identified
We are currently investigating an issue affecting some US Cellular customers calling in to campus and hospital contact centers. The US cellular callers are unable to successfully enter choices when asked to do so in the greetings. Technicians have only been able to recreate this issue for US Cellular callers. All other carriers are working normally. Any US Cellular callers should report this issue to US Cellular.